Skip to content

1. 创建网桥

已安装可跳过

2. 建一个目录存放数据库数据

ℹ️ 提示

这里提前创建目录是因为要更改目录权限,给与 Sqlserver 完整操作权限

bash
mkdir /home/sqlserver
mkdir /home/sqlserver/data
chmod 777 -R /home/sqlserver/data

3. 启动 Sqlserver 容器

ℹ️ 提示

Sqlserver 默认端口是 1443 可自行修改
ACCEPT_EULA=Y,表示接受 Sqlserver 的 最终用户许可协议 ,这是启动 SQL Server 容器所必需的

gms-network网桥 名称
/home/sqlserver/data :宿主机 Sqlserver 数据存放路径
AwLioG0lixkJaxIc : sa 账号的密码,⚠️一定要改成自己密码

⚠️ 说明

Sqlserver2019 要求密码至少8位,少于8位会导致启动失败

bash
  docker run -itd \
  --user root \
  --network gms-network \
  -e 'TZ=Asia/Shanghai' \
  -e 'ACCEPT_EULA=Y' \
  -v /home/sqlserver/data:/var/opt/mssql/data \
  -e 'SA_PASSWORD=AwLioG0lixkJaxIc' \
  -p 1433:1433 \
  --restart=always \
  --name mssql-server \
  mcr.microsoft.com/mssql/server:2019-latest